OS Compatibility

64-bit Compatibility

Beginning with the release of macOS “High Sierra” 10.13.4 and continuing in macOS “Mojave” 10.14, the OS will alert the user when opening a 32-bit application. More information on this issue is available here.

The following (and all newer) versions of our products are 64-bit ready and compatible with the requirements of macOS 10.13.4 and later:

We recommend that you use the latest available versions of BBEdit and Yojimbo.


macOS Catalina (10.15)

We are unable to provide support for our products when used with pre-release versions of macOS.

Note: There are known issues with iCloud support in current macOS Catalina beta versions. One of these issues will prevent BBEdit from launching. If this happens to you, signing out of your iCloud account may allow BBEdit to launch normally.

If you encounter difficulty, please first check using the latest public release of macOS (10.14.5 or later). If the symptom persists, please contact us for assistance. Otherwise, please file a bug report with Apple and they will follow up with us as necessary.

We will update this section with additional information after macOS Catalina is publicly released this fall. For now, our recommendations are:

Apple has announced that macOS Catalina will not run 32-bit applications. This affects TextWrangler, as well as versions of BBEdit older than 12.1.

TextWrangler has been sunsetted, and is now part of BBEdit. Learn more here.

If you are using an older version of BBEdit, please update or upgrade as necessary.


macOS Mojave (10.14)

The following (and all newer) versions of our products are compatible with macOS 10.14 “Mojave”:

TextWrangler has been sunsetted, and is now part of BBEdit. Learn more here.


macOS High Sierra (10.13)

The following (and all newer) versions of our products are recommended for use with macOS 10.13 “High Sierra”:

TextWrangler has been sunsetted, and is now part of BBEdit. Learn more here.

Due to compatibility issues in the OS that we have worked around, we recommend against using any version of our products older than those listed above on macOS 10.13. Please make sure that you are running macOS 10.13.4 or later.

As always, we recommend keeping your OS up to date, in order to get the latest fixes and improvements from Apple.


macOS Sierra (10.12)

The following (and all newer) versions of our products are recommended for use with macOS 10.12 “Sierra”:

Due to bugs in the OS that we have worked around, we recommend against using any version of our products older than those listed above on macOS 10.12.

As always, we recommend keeping your OS up to date, in order to get the latest fixes and improvements from Apple.


OS X El Capitan (10.11)

The following versions of our products are recommended for use with OS X 10.11 “El Capitan”:

Due to bugs in the OS that we have worked around, we recommend against using any version of our products older than those listed above under OS X 10.11.

As always, we recommend keeping your OS up to date, in order to get the latest fixes and improvements from Apple.